summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 295a19180a5e..a8da1b30c5b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Vladimir Ermakov <vooon341@gmail.com>
pkgname=gazebo
-pkgver=1.9.2
+pkgver=3.0.0
pkgrel=2
pkgdesc="A multi-robot simulator for outdoor environments"
arch=('i686' 'x86_64')
@@ -12,20 +12,27 @@ license=('Apache')
# See: http://www.gazebosim.org/user_guide/installation__requirements.html
depends=('boost>=1.40.0' 'curl>=4.0' 'freeglut' 'freeimage>=3.0'
'intel-tbb>=3.0' 'libltdl>=2.4.2' 'libtar>=1.2' 'libxml2>=2.7.7'
- 'ogre-1.8' 'protobuf>=2.3.0' 'qt4' 'sdformat-hg'
+ 'ogre-1.8' 'protobuf>=2.3.0' 'qt4' 'sdformat'
'tinyxml>=2.6.2')
-optdepends=('bullet>=2.81: Bullet support'
+optdepends=('bullet>=2.82: Bullet support'
+ 'simbody>=3.3: simbody support'
+ 'libdart>=3.0: dart support'
'cegui-0.7>=0.7.5: Design custom graphical interfaces'
'ffmpeg>=0.8.3: Playback movies on textured surfaces'
- 'urdfdom: Load URDF files')
+ 'urdfdom: Load URDF files'
+ 'gdal: digital elevation terrains support')
makedepends=('cmake' 'doxygen' 'pkg-config>=0.26')
install="${pkgname}.install"
source=(http://gazebosim.org/assets/distributions/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('9fce4ee44ff496f412b18acf656e6dcf')
+md5sums=('c90e962c91494bdb5283873fa15e6d82')
+provides=('gazebo')
+conflicts=('gazebo')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ find . -type f -exec sed -i 's|include <gdal/|include <|g' {} \;
+
# Create build directory
mkdir -p build && cd build
@@ -33,7 +40,8 @@ build() {
export PKG_CONFIG_PATH="/opt/OGRE-1.8/lib/pkgconfig:$PKG_CONFIG_PATH"
# Run CMake. We skip unit tests.
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_TESTS_COMPILATION:BOOL=False
# Compile Gazebo
@@ -46,7 +54,7 @@ package() {
# Add paths for OGRE-1.8
echo "export LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:/opt/OGRE-1.8/lib" >> ${pkgdir}/usr/share/gazebo/setup.sh
- echo "export LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:/opt/OGRE-1.8/lib" >> ${pkgdir}/usr/share/gazebo-1.9/setup.sh
+ echo "export LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:/opt/OGRE-1.8/lib" >> ${pkgdir}/usr/share/gazebo-3.0/setup.sh
}
# vim:set ts=2 sw=2 et: