summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c1863138a2b..802717d3c60a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
# Contributor: Aris Synodinos <arissynod-gmail-com>
-pkgname=gazebo-hg
-pkgver=11.0.0.38902
+pkgname=gazebo-git
+pkgver=r32276.2369ecd863
pkgrel=1
-pkgdesc="A multi-robot simulator for outdoor environments. Mercurial version."
+pkgdesc="A multi-robot simulator for outdoor environments. Git version."
arch=('i686' 'x86_64')
url="http://gazebosim.org/"
license=('Apache')
# See: http://www.gazebosim.org/tutorials?tut=install_from_source&cat=install
depends=('boost' 'curl' 'freeglut' 'freeimage' 'intel-tbb' 'libccd' 'libltdl'
- 'libtar' 'libxml2' 'ogre=1.9' 'protobuf' 'sdformat>=9' 'ignition-math>=6'
- 'ignition-transport>=8' 'ignition-common>=3' 'ignition-fuel_tools>=4'
- 'ignition-msgs>=5' 'tinyxml2' 'qwt')
+ 'libtar' 'libxml2' 'ogre=1.9' 'protobuf' 'sdformat' 'ignition-math'
+ 'ignition-transport' 'ignition-common' 'ignition-fuel_tools'
+ 'ignition-msgs' 'tinyxml2' 'qwt')
optdepends=('bullet: Bullet support'
'cegui: Design custom graphical interfaces'
'ffmpeg: Playback movies on textured surfaces'
@@ -23,28 +23,23 @@ optdepends=('bullet: Bullet support'
'ruby-ronn: Generate manpages'
'simbody: Simbody support'
'urdfdom: Load URDF files')
-makedepends=('cmake' 'doxygen' 'ignition-cmake>=2' 'mercurial')
+makedepends=('cmake' 'doxygen' 'ruby-ronn' 'git')
install="gazebo.install"
provides=('gazebo')
+conflicts=('gazebo')
-_hgrepo=gazebo
-_hgroot=https://bitbucket.org/osrf
-_dir=${_hgrepo}
+_pkgname=gazebo
-source=("${_hgrepo}"::"hg+${_hgroot}/${_hgrepo}"#branch=default)
-md5sums=('SKIP')
+source=("gazebo"::"git+https://github.com/osrf/gazebo")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_dir}"
-
- local gazebo_major="$(sed -n 's/set (GAZEBO_MAJOR_VERSION \([0-9]\+\))/\1/p' CMakeLists.txt)"
- local gazebo_minor="$(sed -n 's/set (GAZEBO_MINOR_VERSION \([0-9]\+\))/\1/p' CMakeLists.txt)"
- local gazebo_patch="$(sed -n 's/set (GAZEBO_PATCH_VERSION \([0-9]\+\))/\1/p' CMakeLists.txt)"
- printf "%s.%s" "${gazebo_major}.${gazebo_minor}.${gazebo_patch}" "$(hg identify -n)"
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_dir}"
+ cd "${srcdir}/${_pkgname}"
# Create build directory
mkdir -p build && cd build
@@ -60,7 +55,7 @@ build() {
}
package() {
- cd "${srcdir}/${_dir}/build"
+ cd "${srcdir}/${_pkgname}/build"
# Install Gazebo
make DESTDIR="${pkgdir}" install