summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c548636399a..166ded00dab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gbdk-2020
pkgver=3.2
-pkgrel=2
+pkgrel=3
pkgdesc="An updated version of Game Boy Development Kit"
url="https://github.com/Zal0/gbdk-2020"
license=('MIT')
@@ -11,15 +11,13 @@ arch=('x86_64' 'i686')
makedepends=('sdcc')
depends=('sdcc')
conflicts=('gbdk' 'lcc')
-source=("git+https://github.com/basxto/gbdk-2020#commit=01cdbb621afa61de77e394de76161bd8aa65848d")
+source=("git+https://github.com/basxto/gbdk-2020#commit=a48239d6e38738611553d62e43e04546b3f4aece")
#should be merged in the next version
#source=("https://github.com/Zal0/gbdk-2020/archive/v${pkgver}.tar.gz")
sha256sums=('SKIP')
package() {
- sed "s|%prefix%bin/|/usr/bin/|g" -i ${pkgname}/gbdk-support/lcc/gb.c
- make -C ${pkgname} gbdk-build TARGETDIR=/opt/${pkgname} SDCCDIR=/usr/
- make -C ${pkgname} gbdk-install-nosdcc TARGETDIR=/opt/${pkgname} SDCCDIR=/usr/
+ make -C ${pkgname} gbdk-build gbdk-install-nosdcc TARGETDIR=/opt/${pkgname} BINDIR=/usr/bin/ SDCCDIR=/usr/
mkdir -p ${pkgdir}/usr
mkdir -p ${pkgdir}/opt