summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 166ded00dab5..eccbe6cb2739 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
pkgname=gbdk-2020
pkgver=3.2
-pkgrel=3
+pkgrel=4
pkgdesc="An updated version of Game Boy Development Kit"
url="https://github.com/Zal0/gbdk-2020"
license=('MIT')
arch=('x86_64' 'i686')
-makedepends=('sdcc')
+makedepends=('sdcc' 'svn')
depends=('sdcc')
conflicts=('gbdk' 'lcc')
-source=("git+https://github.com/basxto/gbdk-2020#commit=a48239d6e38738611553d62e43e04546b3f4aece")
+# this is branch lcc-patch
+source=("git+https://github.com/basxto/gbdk-2020#commit=87969af9aae690f85439460e73131273af3c8f4a")
#should be merged in the next version
#source=("https://github.com/Zal0/gbdk-2020/archive/v${pkgver}.tar.gz")
sha256sums=('SKIP')
package() {
- make -C ${pkgname} gbdk-build gbdk-install-nosdcc TARGETDIR=/opt/${pkgname} BINDIR=/usr/bin/ SDCCDIR=/usr/
+ make -C ${pkgname} gbdk-build gbdk-support-install gbdk-lib-install TARGETDIR=/opt/${pkgname} BINDIR=/usr/bin/ SDCCDIR=/usr/
mkdir -p ${pkgdir}/usr
mkdir -p ${pkgdir}/opt