summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fe0f62991ef..55f5d849ea44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,45 @@
-# Maintainer: Daniel Isenmann <daniel [at] archlinux.org>
+# Maintainer: a821
+# Contributor: Daniel Isenmann <daniel [at] archlinux.org>
# Contributor: dorphell <dorphell@gmx.net>
pkgname=gc-git
-_pkgname=bdwgc
-pkgver=8.1.99
+pkgver=8.2.0.r513.g515d30eb
pkgrel=1
pkgdesc="A garbage collector for C and C++"
arch=('x86_64')
url="https://www.hboehm.info/gc/"
license=('GPL')
depends=('gcc-libs')
-source=(git+https://github.com/ivmai/bdwgc.git)
-sha512sums=('skip')
+source=($pkgname::git+https://github.com/ivmai/bdwgc.git)
+sha512sums=('SKIP')
conflicts=('gc')
provides=('gc')
-prepare() {
- cd ${_pkgname}
+pkgver() {
+ cd $pkgname
+ git describe | sed -e 's/^v//;s/-/.r/;s/-/./g'
+}
+prepare() {
+ cd $pkgname
+ ./autogen.sh
}
build() {
- cd ${_pkgname}
- ./autogen.sh
+ cd $pkgname
./configure --prefix=/usr --enable-cplusplus --disable-static
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
- cd ${_pkgname}
+ cd $pkgname
make check
}
package() {
- cd ${_pkgname}
+ cd $pkgname
make DESTDIR="${pkgdir}" install
- sed 's|GC_MALLOC 1L|gc 3|g' doc/gc.man |
+ sed 's|GC_MALLOC 1L|gc 3|g' gc.man |
install -Dm644 /dev/stdin "${pkgdir}/usr/share/man/man3/gc.3"
}