summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f84e8d860127..f19bbf4dbf35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,29 @@ pkgname=gcc-arm-none-eabi-bin
pkgver=10_2020_q4_major
pkgrel=1
pkgdesc="GNU Tools ARM Embedded Processors (binary distribution, includes newlib, does NOT include GDB)"
-arch=('x86_64')
+arch=('aarch64' 'x86_64')
depends=('glibc')
optdepends=(
- 'arm-none-eabi-gdb: GNU Debugger for ARM EABI'
+ 'arm-none-eabi-gdb: GNU Debugger for ARM EABI'
)
provides=('gcc-arm-none-eabi'
- 'arm-none-eabi-gcc'
- 'arm-none-eabi-binutils'
- 'arm-none-eabi-newlib'
+ 'arm-none-eabi-gcc'
+ 'arm-none-eabi-binutils'
+ 'arm-none-eabi-newlib'
)
conflicts=('gcc-arm-none-eabi'
- 'arm-none-eabi-gcc'
- 'arm-none-eabi-binutils'
- 'arm-none-eabi-newlib'
+ 'arm-none-eabi-gcc'
+ 'arm-none-eabi-binutils'
+ 'arm-none-eabi-newlib'
)
url="https://developer.arm.com/open-source/gnu-toolchain/gnu-rm"
-source=("https://armkeil.blob.core.windows.net/developer/Files/downloads/gnu-rm/10-2020q4/gcc-arm-none-eabi-10-2020-q4-major-x86_64-linux.tar.bz2")
+source_x86_64=("https://armkeil.blob.core.windows.net/developer/Files/downloads/gnu-rm/10-2020q4/gcc-arm-none-eabi-10-2020-q4-major-x86_64-linux.tar.bz2")
+source_aarch64=("https://armkeil.blob.core.windows.net/developer/Files/downloads/gnu-rm/10-2020q4/gcc-arm-none-eabi-10-2020-q4-major-aarch64-linux.tar.bz2")
license=('custom')
options=(!strip staticlibs)
-sha256sums=('21134caa478bbf5352e239fbc6e2da3038f8d2207e089efc96c3b55f1edcd618')
-md5sums=('8312c4c91799885f222f663fc81f9a31')
-
+sha256sums_x86_64=('21134caa478bbf5352e239fbc6e2da3038f8d2207e089efc96c3b55f1edcd618')
+md5sums_x86_64=('8312c4c91799885f222f663fc81f9a31')
+md5sums_aarch64=('1c3b8944c026d50362eef1f01f329a8e')
package() {
mkdir -p $pkgdir/usr
cd $srcdir/gcc-*/
@@ -34,3 +35,4 @@ package() {
rm -f $pkgdir/usr/bin/arm-none-eabi-gdb*
rm -f $pkgdir/usr/lib/libcc1.so*
}
+