summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66189ae99b9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: zfo <zfoofz1@gmail.com>
+pkgname=gcsfuse
+_pkgname=gcsfuse
+pkgver=0.16
+pkgrel=1
+pkgdesc="A user-space file system for interacting with Google Cloud Storage"
+url="https://github.com/GoogleCloudPlatform/gcsfuse"
+arch=('i686' 'x86_64')
+license=('APACHE')
+makedepends=('git' 'go')
+source=()
+sha256sums=()
+
+build() {
+ GOPATH="$srcdir" go get -v -u github.com/googlecloudplatform/gcsfuse
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm0755 bin/gcsfuse "${pkgdir}/usr/bin/gcsfuse"
+}
+
+# vim:set ts=2 sw=2 et: