summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa227b09e64a..c9a7b83d3720 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Aviel Warschawski <mail@aviel.org>
pkgname=gdb-multiarch
-pkgver=8.3
+pkgver=8.3.1
pkgrel=1
pkgdesc='The GNU Debugger for all gdb supported architectures (i386/arm/mips...)'
arch=(i686 x86_64)
url='http://www.gnu.org/software/gdb/'
license=(GPL3)
-depends=(xz ncurses expat python guile2.0 gdb-common)
+depends=(xz ncurses expat python guile2.0 gdb-common=$pkgver)
options=(!emptydirs)
-source=(https://ftp.gnu.org/gnu/gdb/gdb-8.3.tar.xz{,.sig})
-sha256sums=('802f7ee309dcc547d65a68d61ebd6526762d26c3051f52caebe2189ac1ffd72e'
- 'SKIP')
+source=(https://ftp.gnu.org/gnu/gdb/gdb-8.3.1.tar.xz{,.sig}
+ python-3.8.patch)
+sha256sums=('1e55b4d7cdca7b34be12f4ceae651623aa73b2fd640152313f9f66a7149757c4'
+ 'SKIP'
+ '77d93856d1272e30494e8180e2fb3adc124cb939eee6447f45326087e49cdd6e')
validpgpkeys=('F40ADB902B24264AA42E50BF92EDB04BFF325CF3') # Joel Brobecker <brobecker@adacore.com>
prepare() {
cd gdb-$pkgver
+ patch -Np1 -i ../python-3.8.patch
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
}
@@ -24,8 +27,7 @@ build() {
./configure \
--enable-targets=all \
- --prefix=/build \
- --enable-languages=c,c++ \
+ --enable-languages=all \
--enable-multilib \
--enable-interwork \
--with-system-readline \