summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d3e5bd480cb..abbc01cdc2b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=gdb11
pkgver=11.2
-pkgrel=1
+pkgrel=2
pkgdesc="GNU debugger (version 11) for compability with clion remote debugging"
arch=(x86_64)
url="https://www.gnu.org/software/gdb"
license=('GPL')
-makedepends=(gmp mpfr)
-depends=(xz libmpc gdb) # GDB is included to prevent conflicts with it - otherwise this package won't function
+makedepends=('gmp' 'mpfr')
+depends=('xz' 'libmpc' 'gdb' 'boost' 'boost-libs') # GDB is included to prevent conflicts with it - otherwise this package won't function
replaces=("i686-elf-gdb")
conflicts=("i686-elf-gdb")
source=("https://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz")
@@ -17,13 +17,13 @@ sha256sums=('1497c36a71881b8671a9a84a0ee40faab788ca30d7ba19d8463c3cc787152e32')
OPTIONS=(!strip)
prepare() {
- mkdir "gdb11-build"
+ mkdir "gdb11-build"
}
build() {
- cd "gdb11-build"
+ cd "gdb11-build"
../gdb-${pkgver}/configure --prefix=/opt/gdb11
- make -j$(nproc)
+ make -j$(nproc)
}
package() {