summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD40
1 files changed, 10 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0be6c9a0af9e..bfeedf20667c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,51 +3,31 @@
# Special thanks to RyanTheAllmighty for making hyper-appimage
pkgname="gdlauncher-bin"
_pkgname="gdlauncher"
-pkgver="1.1.14"
+pkgver="1.1.15"
pkgrel=1
arch=('x86_64')
pkgdesc="GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience"
url="https://gdevs.io"
license=('GPL3')
-makedepends=('gendesk' 'imagemagick')
+makedepends=('tar' 'xz')
depends=('libnotify' 'libxss' 'libxtst' 'libindicator-gtk3' 'libappindicator-gtk3')
provides=('gdlauncher')
-conflicts=('gdlauncher' 'gdlauncher-appimage' 'gdlauncher-git' 'gdlauncher-classic')
-source_x86_64=("GDLauncher-${pkgver}.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.zip"
- "https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png")
-md5sums_x86_64=('332fd5cc4172a5eeb1c849781f6b38e7'
- 'af0ce1364e34f49af3793bf8193c5369')
-icon_sizes=(48 128 256 1024)
-
-prepare() {
- # Generate .desktop
- gendesk --pkgname "GDLauncher" --pkgdesc "${pkgdesc}" --icon ${_pkgname} --exec "/usr/bin/${_pkgname}" --categories "Application;Game" -n -f
-}
+conflicts=('gdlauncher' 'gdlauncher-beta' 'gdlauncher-beta-bin' 'gdlauncher-appimage' 'gdlauncher-git' 'gdlauncher-classic')
+source_x86_64=("GDLauncher-${pkgver}.deb::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.deb")
+md5sums_x86_64=('686a94726312d6579d0d961b84543111')
package() {
- # install the main files.
- install -d -m755 "${pkgdir}/opt/${pkgname}/"
- cp -r "${srcdir}/"* "${pkgdir}/opt/${pkgname}/"
- rm "${pkgdir}/opt/${pkgname}/"{icon*.png,GDLauncher-${pkgver}.zip,GDLauncher.desktop} # remove symlinked source files
-
- # desktop entry
- install -d -m755 "${pkgdir}/usr/share/applications/"
- install -D -m644 "${srcdir}/GDLauncher.desktop" "${pkgdir}/usr/share/applications/GDlauncher.desktop"
-
- # install the icons
- for size in "${icon_sizes[@]}"; do
- install -d -m755 "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/"
- convert "${srcdir}/icon.png" -resize "${size}x${size}" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/${_pkgname}.png"
- done
+ # Extract data folder from .deb archive
+ tar xf "${srcdir}/data.tar.xz" --directory=$pkgdir
# fix file permissions - all files as 644 - directories as 755
find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;
find "${pkgdir}/"{opt,usr} -type f -exec chmod 644 {} \;
- # make sure the main binary has the right permissions
- chmod +x "${pkgdir}/opt/${pkgname}/${_pkgname}"
+ # make sure the main and 7za binary have the right permissions
+ chmod a+x "${pkgdir}/opt/GDLauncher/"{${_pkgname},7za}
# link the binary
install -d -m755 "${pkgdir}/usr/bin/"
- ln -sr "${pkgdir}/opt/${pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ ln -sr "${pkgdir}/opt/GDLauncher/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}