summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4330470e3828..2b4cf8cb50f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
pkgname=gdlmm
pkgver=3.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="C++ bindings for the gdl library"
arch=('x86_64' 'i686')
url="http://git.gnome.org/browse/gdlmm/"
depends=('gdl' 'gtkmm3')
options=(!libtool !emptydirs)
license=('LGPL')
-source=("http://ftp.gnome.org/pub/GNOME/sources/gdlmm/3.3/$pkgname-$pkgver.tar.xz")
-sha256sums=('cf3253be052737332b2b6e9dbd6f62d79cbc3f3398497158c0099dbc45741a46')
+source=("http://ftp.gnome.org/pub/GNOME/sources/gdlmm/3.3/$pkgname-$pkgver.tar.xz"
+ "0001-Don-t-wrap-gdl_dock_layout_get_layouts_ui.patch")
+sha256sums=('cf3253be052737332b2b6e9dbd6f62d79cbc3f3398497158c0099dbc45741a46'
+ '8fb0d920c5c3d4279738f048cbff65b5b4fa544c9f004f8e64d39e54f52653d5')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # Fix build with gdl 3.6
+ patch -Np1 -i "$srcdir/0001-Don-t-wrap-gdl_dock_layout_get_layouts_ui.patch"
+
./configure --prefix=/usr --sysconfdir=/etc
make
}