summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 32 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1c040b02db4..f74c452af90d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,46 @@
-# Maintainer: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
+# Maintainer:
+# Contributor: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
# Contributor: YamashitaRen <lemaitre(dot)lotus(at)gmail(dot)com>
-pkgname=geany-highlightselectedword
+_pkgname="geany-highlightselectedword"
+pkgname="$_pkgname"
pkgver=20160801
-pkgrel=1
-pkgdesc="Geany plugin that highlights the word that is currently selected in the editor"
+pkgrel=2
+pkgdesc="Geany plugin that highlights all instances of the currently selected word"
url="https://sourceforge.net/projects/geanyhighlightselectedword/"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('geany')
+
+depends=(
+ 'geany'
+
+ ## implicit
+ #at-spi2-core
+ #cairo
+ #gdk-pixbuf2
+ #glib2
+ #gtk3
+ #harfbuzz
+ #pango
+ #zlib
+)
+
+_pkgsrc="GeanyHighlightSelectedWord_2016-08-01T00-53-19"
source=("https://downloads.sourceforge.net/project/geanyhighlightselectedword/GeanyHighlightSelectedWord_2016-08-01T00-53-19.zip")
-md5sums=('91b9a703d3d0e6ec22c22908ce6e4e9b')
+sha256sums=('ab9d8dd680c8b446e4433bec5c3c2a329d30c1b65c2e2ecdaff95444454acfcd')
+
+prepare() {
+ cd "$_pkgsrc"
+ sed -E -e 's&\bconst const\b&const&' -i GeanyHighlightSelectedWord.c
+}
build() {
- cd "${srcdir}/GeanyHighlightSelectedWord_2016-08-01T00-53-19"
+ cd "$_pkgsrc"
make
}
package() {
- cd "${srcdir}/GeanyHighlightSelectedWord_2016-08-01T00-53-19"
-
- install -Dm644 GeanyHighlightSelectedWord.so \
- "${pkgdir}/usr/lib/geany/GeanyHighlightSelectedWord.so"
-}
+ cd "$_pkgsrc"
-# vim:set ts=2 sw=2 cc=80 et:
+ install -Dm644 GeanyHighlightSelectedWord.so "$pkgdir/usr/lib/geany/GeanyHighlightSelectedWord.so"
+}