summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05b9bd2f2920..1ac90cef9608 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# {former}Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: eht16 <enrico.troeger@uvena.de>
# Contributor: Addict7 <nicolasfloquet@gmail.com>
-
+
pkgname=geany-plugins-git
-pkgver=1.28.0
+pkgver=1.29.0.r5.gc8b7805
pkgrel=1
pkgdesc='Various plugins for Geany'
arch=('x86_64' 'i686')
@@ -13,27 +13,26 @@ license=('GPL')
depends=('geany-git' 'vte' 'lua' 'libwebkit' 'ctpl' 'gpgme' 'gtkspell' 'hicolor-icon-theme')
makedepends=('git' 'libtool' 'python' 'gpgme' 'ctpl' 'lua' 'intltool')
optdepends=('hspell: hebrew spell checker')
-install="$pkgname.install"
provides=('geany-plugins')
conflicts=('geany-plugins-svn' 'geany-plugins')
-source=('https://github.com/geany/geany-plugins/archive/$pkgver.tar.gz')
+source=('git+https://github.com/geany/geany-plugins.git')
md5sums=('SKIP')
-
+
pkgver() {
cd geany-plugins
- git describe --tags | sed 's/-/./g'
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-
+
build() {
cd geany-plugins
./autogen.sh
./configure --prefix=/usr --disable-geanypy
make build
}
-
+
package() {
cd geany-plugins
make install DESTDIR="$pkgdir"
}
-
+
# vim:set ts=2 sw=2 et: