summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23c8d96f7e08..0dad6270f65f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,32 @@
pkgname=geany-snippets
pkgver=1
-pkgrel=5
+pkgrel=6
pkgdesc="Snippets for Geany"
arch=('any')
url="http://www.geany.org/Download/Extras#snippets"
license=('GPL')
depends=('geany')
-source=(http://lara.craft.net.br/snippets.conf
+source=(ChangeLog
+ 'tcl.conf::http://advamacs.com/pub/snippets.conf'
+ 'python.conf::http://download.geany.org/contrib/python_snippets.conf'
+ 'htmlphp.conf::https://dl.dropboxusercontent.com/u/668529/conf/snippets.conf'
+ 'latex.conf::http://download.geany.org/contrib/latex_snippets.conf'
$pkgname.install)
-
install=$pkgname.install
-
-md5sums=('e6c32d7cb454deffe86cb32f62840f34'
+changelog=ChangeLog
+md5sums=('7f3b01c191a525394508a1ecd33387e1'
+ '2703567c4b47e3c27404033034829ae7'
+ '0fd08ca51cbf862f3fb74c87ea455077'
+ 'e6c32d7cb454deffe86cb32f62840f34'
+ '2dce08133c30e6beca4b5a398dbb0676'
'2011316bb069109d9fc3dbcfb784a73f')
+prepare() {
+ cat {tcl,python,htmlphp,latex}.conf > snippets.conf
+}
+
package() {
- cd "$srcdir"
-
- install -Dm644 snippets.conf "$pkgdir"/usr/share/geany/snippets.conf.new
+ install -Dm644 snippets.conf "$pkgdir"/usr/share/geany/snippets.conf.new
}