summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3eea62e7fb51..b39ed56549c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=gedit-plugin-markdown_preview-git
-pkgver=r170.cc711c0
-pkgrel=1
+pkgver=r172.b1f81cc
+pkgrel=2
pkgdesc="A gedit plugin previewing markdown (.md) documents"
arch=('any')
url="https://github.com/maoschanz/gedit-plugin-markdown_preview"
@@ -16,14 +16,24 @@ optdepends=('pymdown-extensions: extra Python Markdown extensions'
'texlive-fontsextra: export to PDF with pandoc (lmodern)')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/maoschanz/gedit-plugin-markdown_preview.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/maoschanz/gedit-plugin-markdown_preview.git'
+ 'https://github.com/maoschanz/gedit-plugin-markdown_preview/pull/55.patch')
+sha256sums=('SKIP'
+ '9cc3f3800aa6f4d02e8e185581c266b2286aa5c0f1d3f768fc32269c2582c4f6')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # fixes #46 for export_assistant.py
+ # https://github.com/maoschanz/gedit-plugin-markdown_preview/issues/46
+ patch -Np1 -i ../55.patch
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
install -Dm644 org.gnome.gedit.plugins.markdown_preview.gschema.xml -t \