summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66352bedfc6b..5a5db1ab0a34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
pkgname=geis
-pkgver=2.2.16
-pkgrel=2
+pkgver=2.2.17
+pkgrel=1
pkgdesc="Implementation of the GEIS (Gesture Engine Interface and Support) interface."
arch=('i686' 'x86_64')
url="https://launchpad.net/geis"
@@ -14,27 +14,24 @@ provides=('utouch-geis')
conflicts=('utouch-geis')
replaces=('utouch-geis')
options=('!emptydirs' '!libtool')
-source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz" \
- "http://bazaar.launchpad.net/~ken-vandine/geis/lp1428314/diff/328?context=3")
-md5sums=('550c78b5185b835b80dba14537c2c83d'
- '2ff7e280b846f363691c3749930bd79d')
+source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.xz")
+md5sums=('2ff9d76a3ea5794516bb02c9d1924faf')
+
prepare() {
cd "$pkgname-$pkgver"
- patch -p0 -i '../328?context=3'
}
build() {
cd "$pkgname-$pkgver"
## add -Wno-format in CFLAGS see FS#34658
- CFLAGS="$CFLAGS -Wno-format" ./configure --prefix=/usr --disable-static
+ CFLAGS="$CFLAGS -Wno-format -Wno-misleading-indentation" ./configure --prefix=/usr --disable-static
make
}
package() {
cd "$pkgname-$pkgver"
-
make DESTDIR="${pkgdir}/" install
}