summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 12 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1700ac91121..6e6bc88f65dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,26 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: snafu <regflx@web.de>
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: snafu <regflx@web.de>
pkgname=genders
-pkgver=1.14
+pkgver=1.20
pkgrel=1
-pkgdesc="Static cluster configuration datatbase used for cluster configuration management."
-arch=(x86_64 i686)
-url="http://sourceforge.net/projects/genders"
+pkgdesc="Static cluster configuration database used for cluster configuration management."
+arch=('x86_64' 'i686')
+url='https://computing.llnl.gov/linux/genders.html'
license=('GPL')
-groups=()
-depends=()
-makedepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=(http://sourceforge.net/projects/genders/files/genders/$pkgver-$pkgrel/$pkgname-$pkgver.tar.gz)
-noextract=()
-md5sums=('8d645f331fd8636b2d8e830c65d06255')
+source=("http://sourceforge.net/projects/genders/files/genders/$pkgver-$pkgrel/$pkgname-$pkgver.tar.gz"
+ '624078.patch')
+md5sums=('26a3bc4b6d5eeae3ade7b719c6165d85'
+ '76431ec248c0ee9a2d1b9971cc13ce57')
build() {
cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr
+ patch -p1 < ../624078.patch
+ ./configure --without-python-extensions
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
-
make DESTDIR="$pkgdir/" install
}