summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 30 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7eb5cc7a2667..c03a6603bea7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,43 @@
-# Maintainer: Darren Ng <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
-
+# Maintainer: "Darren Ng <$(base64 --decode <<<VW4xR2ZuQGdtYWlsLmNvbQo=)>"
pkgname=genimage
-pkgver=13
+pkgver=14
pkgrel=1
pkgdesc="tool to generate multiple filesystem and flash images from a tree"
-arch=("x86_64")
-url="https://github.com/pengutronix/genimage"
-license=("GPL2")
-depends=("confuse")
-
-source=("$pkgname-$pkgver.tar.gz::https://github.com/pengutronix/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('c9f5c5c48a98c72d358cd18aca46e69a74c9eeaef6ee4a2497b4c1d2bee467e2')
+arch=($CARCH)
+url=https://github.com/pengutronix/$pkgname
+license=(GPL2)
+depends=(confuse)
+# https://sphinx-rtd-theme.readthedocs.io/en/stable/
+# makedepends=(python-sphinx python-sphinx_rtd_theme)
+source=($pkgname-$pkgver.tar.gz::https://github.com/pengutronix/$pkgname/archive/v$pkgver.tar.gz
+ index.html::https://github.com/pengutronix/genimage/blob/v14/README.rst)
+sha1sums=(043fed792abe0280b830c61765fd44870f1fdf61 SKIP)
build() {
- cd "$pkgname-$pkgver"
+
+ cd $pkgname-$pkgver
+ # cp configure.ac{,\~}
+ # autoupdate # Corrupts ./configure
+ # diff -u configure.ac{\~,}
./autogen.sh
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --enable-silent-rules --disable-dependency-tracking
make
-}
-check() {
- cd "$pkgname-$pkgver"
- make -k check
+ # https://www.sphinx-doc.org/en/master/man/sphinx-quickstart.html
+ # sphinx-quickstart --sep -p genimage -a "Michael Olbrich" -v 14 -r 14 -l en -d master_doc=README --ext-autodoc --ext-viewcode --ext-githubpages --no-batchfile .
+ # https://www.sphinx-doc.org/en/master/man/sphinx-build.html
+ # sphinx-build -b dirhtml -d .doctrees -n -v . ./build
+
}
+# https://github.com/pengutronix/genimage/issues/157
+# check() {
+# cd $pkgname-$pkgver
+# make -k check
+# }
+
package() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
+ install -vdm755 "$pkgdir/usr/share/doc/$pkgname"; cp -Lv "$srcdir/index.html" "$_"
}