summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09bde9092e74..b576b7162ebf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Alexander Chaplin Braz <contact@alexchaplinbraz.com>
pkgname='genrepass-bin'
_pkgname='genrepass'
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc='Generate a readable password from an ordered list of words extracted from text'
arch=('x86_64' 'i686')
url='https://github.com/AlexChaplinBraz/genrepass-cli'
license=('MIT')
-depends=('gcc-libs' 'libxcb' 'glibc' 'libxau' 'libxau')
+depends=('libxcb' 'gcc-libs' 'glibc')
conflicts=('genrepass' 'genrepass-git')
-source_x86_64=("$url/releases/download/$pkgver/genrepass-x86_64-unknown-linux-gnu-$pkgver.tar.gz")
-source_i686=("$url/releases/download/$pkgver/genrepass-i686-unknown-linux-gnu-$pkgver.tar.gz")
-sha256sums_x86_64=('98a06b8865ed624fa4b491dfc495161a6ffde80a2f4762d23913602d3c3b939f')
-sha256sums_i686=('824db896fd09ca7c61d86392c0f7782fdedda5785903de36dd114a2937469550')
+source_x86_64=("$url/releases/download/$pkgver/$_pkgname-$pkgver-x86_64-unknown-linux-gnu.tar.gz")
+source_i686=("$url/releases/download/$pkgver/$_pkgname-$pkgver-i686-unknown-linux-gnu.tar.gz")
+sha256sums_x86_64=('')
+sha256sums_i686=('')
package() {
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "$srcdir/$_pkgname-$pkgver-*/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$srcdir/$_pkgname-$pkgver-*/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}