summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4da510410d2f..6c4e82c5c18d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=geographiclib
_pkgname=GeographicLib
-pkgver=1.52
+pkgver=2.0
pkgrel=1
pkgdesc="Set of C++ classes for conversions between geographic, UTM, UPS, MGRS, geocentric, and local cartesian coordinates, for gravity, geoid height, and geomagnetic field calculations and for solving geodesic problems. Geotrans replacement."
arch=('i686' 'x86_64')
-url="http://geographiclib.sourceforge.io/"
-license=('custom') # MIT/X11
+url="https://geographiclib.sourceforge.io/"
+license=('MIT')
depends=('bash')
makedepends=('gcc' 'make' 'cmake')
options=('staticlibs')
-source=(http://downloads.sourceforge.net/project/geographiclib/distrib/${_pkgname}-${pkgver}.tar.gz)
-md5sums=('52407e8380335957377c6ac6118ce6e3')
+source=(https://sourceforge.net/projects/geographiclib/files/distrib-C%2B%2B/${_pkgname}-${pkgver}.tar.gz/download)
+md5sums=('dafd8c995758f3b9205702a8019e6ca3')
install=geographiclib.install
@@ -22,7 +22,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
cmake ./ \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGEOGRAPHICLIB_LIB_TYPE=BOTH
+ -DBUILD_BOTH_LIBS=ON
make
}