summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..397c87677f3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=geojsonhint
+_npmver=1.2.0
+pkgname=nodejs-geojsonhint # All lowercase
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Validate and sanity-check geojson files (geojsonlint)"
+arch=(any)
+url="https://github.com/mapbox/geojsonhint#readme"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(750ee17419e08c29cbf552e867038c4565c521e5)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: