summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dac45d7ff36a..6d64090b24bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Andrés J. Díaz <ajdiaz@ajdiaz.me>
pkgname=geomyidae
-pkgver=0.34
+pkgver=0.50.1
pkgrel=1
pkgdesc='Small C-based gopherd'
arch=('x86_64')
@@ -9,8 +9,10 @@ url='https://gopher.floodgap.com/gopher/gw?gopher://bitreich.org:70/1/scm/geomyi
license=('MIT')
backup=('var/gopher/CGI'
'var/gopher/index.gph')
-source=("ftp://bitreich.org/releases/${pkgname}/${pkgname}-v${pkgver}.tgz")
-sha256sums=('2580ad0f229cd3f5c33495975a708679aeaf5276c06ec8d55871d7f69b216eb0')
+source=("ftp://bitreich.org/releases/${pkgname}/${pkgname}-v${pkgver}.tar.lz")
+sha512sums=(
+ 'ecfed96cd456ff0bafb09527abdf4d50183331f9b4462cdfc37cdcb1274dd72aa9304da2d962670a37503500b27713fd24a179691aa5d6a613776cf452319f24'
+)
build() {
make -C "${pkgname}-v${pkgver}"
@@ -19,10 +21,10 @@ build() {
package() {
cd "${pkgname}-v${pkgver}"
make DESTDIR="${pkgdir}" PREFIX="/usr" install
- install -Dm644 -t "${pkgdir}/var/gopher" {CGI,index.gph}
+ install -Dm644 -t "${pkgdir}/var/gopher" index.gph
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" {LINKS,README}
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/rc.d" 'rc.d/'*
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${startdir}/LICENSE"
}
# vim: ts=2 sw=2 et: