summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c5706a11389
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alessandro Ferrari <alessandroferry@protonmail.com>
+pkgname=get-media-playing-git
+pkgver=1.0.r2.6e8c903
+pkgrel=1
+epoch=
+pkgdesc="Simple script to get the current media playing in the system. Useful in status bars"
+arch=(x86_64)
+url="https://github.com/Ferryistaken/get-media-playing.git"
+license=('MIT')
+groups=()
+depends=(playerctl bash)
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(get-media-playing)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd get-media-playing
+}
+
+check() {
+ echo "Remember to always read your PKGBUILDs before installing"
+}
+
+package() {
+ cd get-media-playing
+ install -D get-media-playing.sh ${pkgdir}
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}