summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ac54ad399fa..9129847924b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Phil Ruffwind <rf@rufflewind.com>
pkgname=ghc-pristine
pkgver=8.6.3
-pkgrel=1
-pkgdesc="Symlinks to GHC with only boot libs, useful for building static binaries"
+pkgrel=2
+pkgdesc="Symlinks to GHC with only boot libs, useful for building static binaries (see PKGBUILD for details)"
arch=(any)
url=https://www.haskell.org/ghc/
license=(custom)
depends=(ghc)
+optdepends=("ghc-static: needed to build static binaries")
# This package provides symbolic links to the Glasgow Haskell Compiler, but
# with the global package database restricted to only boot libraries. This is
@@ -14,8 +15,15 @@ depends=(ghc)
# the official haskell-* packages, which only offer dynamic libraries and
# makes cabal hopelessly confused.
#
-# To use this package, you just need to configure cabal
+# See also: https://wiki.archlinux.org/index.php/Haskell#Static_linking
+#
+# To use this package, make sure ghc-static is installed and the flag
# --with-compiler=/usr/share/ghc-pristine/bin/ghc
+# is passed to all cabal invocations. You can also add this to your
+# ~/.cabal/config file.
+#
+# For cabal new-builds, you just need to run this command once:
+# cabal v2-configure --with-compiler=/usr/share/ghc-pristine/bin/ghc
pkgver() {
ghc --version | sed -n 's/^.*version \([0-9.]*\)/\1/p'