summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 53 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 618f5d8ce8ea..496f98d91c30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,62 @@ pkgver=7.10.3
pkgrel=7
pkgdesc="GHC binaries for Raspberry Pi from Raspian repositories"
arch=('armv6h')
-url="https://www.haskell.org/ghc/"
+url='https://www.haskell.org/ghc/'
license=('custom')
-conflicts=('ghc')
-provides=(haskell-array haskell-base haskell-binary haskell-bin-package-db haskell-bytestring haskell-cabal haskell-containers haskell-deepseq haskell-directory haskell-filepath haskell-ghc-prim haskell-haskeline haskell-hoopl haskell-hpc haskell-integer-gmp haskell-pretty haskell-process haskell-template-haskell haskell-terminfo haskell-time haskell-transformers haskell-unix haskell-xhtml)
-depends=(gcc gmp libffi perl)
+depends=('perl' 'gmp' 'gcc' 'libffi')
makedepends=('dpkg')
+conflicts=('ghc')
+provides=("ghc=$pkgver"
+ 'haskell-array=0.5.1.0'
+ 'haskell-base=4.8.2.0'
+ 'haskell-binary=0.7.5.0'
+ 'haskell-bin-package-db=0.0.0.0'
+ 'haskell-bytestring=0.10.6.0'
+ 'haskell-cabal=1.22.5.0'
+ 'haskell-containers=0.5.6.2'
+ 'haskell-deepseq=1.4.1.1'
+ 'haskell-directory=1.2.2.0'
+ 'haskell-filepath=1.4.0.0'
+ 'haskell-ghc-prim=0.4.0.0'
+ 'haskell-haskeline=0.7.2.1'
+ 'haskell-hoopl=3.10.0.2'
+ 'haskell-hpc=0.6.0.2'
+ 'haskell-integer-gmp=1.0.0.0'
+ 'haskell-pretty=1.1.2.0'
+ 'haskell-process=1.2.3.0'
+ 'haskell-template-haskell=2.10.0.0'
+ 'haskell-terminfo=0.4.0.1'
+ 'haskell-time=1.5.0.1'
+ 'haskell-transformers=0.4.2.0'
+ 'haskell-unix=2.7.1.0'
+ 'haskell-xhtml=3000.2.1')
+replaces=('haskell-array'
+ 'haskell-base'
+ 'haskell-binary'
+ 'haskell-bin-package-db'
+ 'haskell-bytestring'
+ 'haskell-cabal'
+ 'haskell-containers'
+ 'haskell-deepseq'
+ 'haskell-directory'
+ 'haskell-filepath'
+ 'haskell-ghc-prim'
+ 'haskell-haskeline'
+ 'haskell-hoopl'
+ 'haskell-hpc'
+ 'haskell-integer-gmp'
+ 'haskell-pretty'
+ 'haskell-process'
+ 'haskell-template-haskell'
+ 'haskell-terminfo'
+ 'haskell-time'
+ 'haskell-transformers'
+ 'haskell-unix'
+ 'haskell-xhtml')
+install="$pkgname.install"
+options=('staticlibs')
install="${pkgname}.install"
+options=('staticlibs')
_filename="ghc_${pkgver}-${pkgrel}+rpi1_armhf.deb"
source=("http://archive.raspbian.org/raspbian/pool/main/g/ghc/$_filename")
sha256sums=('61b90723e5a10cf32964bb7292f4ae914f45dcbc2e9bd169f3b4fe137fe3dbc4')