summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9e2040b734e..aef172ef707d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=ghdl
-pkgver=0.35
-pkgrel=3
-_gccver=7.3.0
-_islver=0.18
+pkgver=0.37
+pkgrel=1
+_gccver=9.2.0
+_islver=0.22.1
arch=('aarch64' 'x86_64')
pkgdesc='VHDL simulator'
url='https://github.com/ghdl/ghdl'
@@ -11,20 +11,19 @@ makedepends=('gcc-ada' 'git')
install=ghdl.install
options=(!emptydirs staticlibs)
-# This is the earliest commit that works with gcc-ada 8.1
source=(
- "git+https://github.com/ghdl/ghdl#commit=319092de002423fcd5f624d2f026176503ab6018"
+ "git+https://github.com/ghdl/ghdl#tag=v${pkgver}"
"https://gcc.gnu.org/pub/gcc/releases/gcc-${_gccver}/gcc-${_gccver}.tar.xz"
"http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
)
sha256sums=(
'SKIP'
- '832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c'
- '6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
+ 'ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206'
+ '1a668ef92eb181a7c021e8531a3ca89fd71aa1b3744db56f68365ab0a224c5cd'
)
prepare() {
- ln -s gcc-${_gccver/+/-} gcc
+ [[ ! -d gcc ]] && ln -s gcc-${_gccver/+/-} gcc
cd ghdl
./configure --prefix=/usr --with-gcc="${srcdir}/gcc"