summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 233ca44ae029..3ebffa5835c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -162,4 +162,11 @@ package() {
find "usr/bin" "usr/share/info" \
-maxdepth 1 -mindepth 1 -not -name 'ghdl*' \
-exec rm -rf {} +
+
+ # In case it does not exist, create symlink libghdl.so
+ local _gso=`ls "${pkgdir}/usr/lib/" | grep -e '^libghdl-.*\.so$' | head -n 1`
+ if [[ -n "$_gso" ]] ; then
+ ln -s "$_gso" "${pkgdir}/usr/lib/libghdl.so"
+ fi
+
}