summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55279a49b22d..2b118ebdcfef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=9.0.2+10+g49c2010
_d2j=2.0
_yajsw=12.12
_hfsx=0.21
-pkgrel=1
+pkgrel=2
pkgdesc='Software reverse engineering framework (git)'
arch=(x86_64)
url=https://github.com/NationalSecurityAgency/ghidra
@@ -14,6 +14,7 @@ conflicts=(ghidra ghidra-bin)
depends=('java-environment>=11' bash)
makedepends=(gradle unzip)
source=(git+$url
+ git+$url-data
https://github.com/pxb1988/dex2jar/releases/download/$_d2j/dex-tools-$_d2j.zip
https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/android4me/AXMLPrinter2.jar
https://sourceforge.net/projects/yajsw/files/yajsw/yajsw-stable-$_yajsw/yajsw-stable-$_yajsw.zip
@@ -22,6 +23,7 @@ noextract=(AXMLPrinter2.jar
yajsw-stable-$_yajsw.zip
hfsexplorer-${_hfsx/./_}-bin.zip)
sha512sums=('SKIP'
+ 'SKIP'
'c4a6c72ea09b58a44fcb8918cfada600467f10f99a02b53d2436ac68295e73c8daf9ba0a8bc7160ba1e28e87f032ee034435ebe40af35b6e2fe9fa4607581358'
'c1168ec913f1fbb0675915d4fd865ec9a8e8573f6c8aedcb6e68166f61f11aeaececc7548d54d78134843c0102c57d6350973f6d3027d0ffdae52a5c57a7f601'
'0ff5a228ae1c5251c8ba59f9bcd9b4a199b0caaf688f6eccba42c3d227784d8f56f9164b2fad73fc173ec314340c036144123ce152fe911013df5598bd708944'
@@ -53,7 +55,7 @@ allprojects {
}
EOF
- # Copy libs to common folder
+ # Add libs
install -Dm 644 ../dex2jar-$_d2j/lib/dex-*.jar \
../AXMLPrinter2.jar \
../hfsx/lib/{csframework,hfsx*,iharder-base64}.jar \
@@ -63,8 +65,11 @@ EOF
ln -sf ghidra ../ghidra.bin
install -Dm 644 ../yajsw-stable-$_yajsw.zip -t Ghidra/Features/GhidraServer
- # Fix bug where no license is found for the YAJSW zip
- sed -i '/FileTree tree/a\\t\texclude "yajsw-stable-**.zip"' gradleScripts/ip.gradle
+ # Ignore lack of licensing for YAJSW zip and packed FID datasets
+ sed -i '/FileTree tree/a\\t\texclude "yajsw-stable-**.zip"\n\t\texclude "src/main/fidb/**.fidb"' gradleScripts/ip.gradle
+
+ # Add FID datasets
+ install -Dm 644 ../ghidra-data/FunctionID/*.fidb -t Ghidra/Features/FunctionID/src/main/fidb
}
build() {
@@ -79,8 +84,7 @@ build() {
package() {
cd ghidra
install -d "$pkgdir"/{opt,usr/bin}
- _ghidra=ghidra_${pkgver:0:5}_PUBLIC_`date +"%Y%m%d"`_$_platform.zip
- unzip -u build/dist/$_ghidra -d "$pkgdir"/opt
+ unzip -u build/dist/ghidra_${pkgver:0:5}_PUBLIC_`date +"%Y%m%d"`_$_platform.zip -d "$pkgdir"/opt
mv "$pkgdir"/opt/ghidra{_${pkgver:0:5},}
ln -s /opt/ghidra/ghidraRun "$pkgdir"/usr/bin/ghidra
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/ghidra/LICENSE