summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd33bbdbf55e..c7da23d675e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=ghost-bin
-pkgver=2_0_2
+pkgver=3_1
pkgrel=1
pkgdesc="Xboard compatible chess engine - Precompiled binary from the official website"
arch=('i686' 'x86_64')
@@ -12,38 +12,41 @@ optdepends=(
)
install=install
-_urlprefix='http://www.ghostchess.de/ghost2/linux'
+_urlprefix='http://www.ghostchess.de/ghost3/linux'
if test "$CARCH" == x86_64; then
- source=("${_urlprefix}/ghost2_x64_linux_v${pkgver}.tgz"
+ source=("${_urlprefix}/ghost3_linux64_v${pkgver}.tar.xz"
LICENSE)
- sha256sums=('ccafb414e4bf6384210ce1bd8bcf1d3cf90e410c6b70ba08085e06a587169ac0'
+ sha256sums=('1a4d99dc73b06da6e7210d7da80e53dcbf1d67f77f27c435c805fbe6a6bc147e'
'SKIP')
- _binary=ghost2_x64_linux_v${pkgver}
+ _dir=ghost3_linux64_v${pkgver/_/.}_64bit
+
+ _binary=ghost_v${pkgver/_/.}-64bit
+ # to use the slower version without POPCNT instruction:
+ #_binary=ghost_v${pkgver/_/.}-no-popcnt-64bit
else
- source=("${_urlprefix}/ghost2_x86_linux_v${pkgver}.tgz"
+ source=("${_urlprefix}/ghost3_linux32_v${pkgver}.tar.xz"
LICENSE)
- sha256sums=('e63ba38ebe48a77401dd9fb9207bd2c312141e2561bc9d2c2a4faa4767a2398b'
+ sha256sums=('1c10e9e087b44a9c9af18c3a1d220900c849bace519d5b943510b734a03c17a1'
'SKIP')
- _binary=ghost2_x86_linux_v${pkgver}
+ _dir=ghost3_linux32_v${pkgver/_/.}_32bit
+ _binary=ghost_v${pkgver/_/.}-32bit
fi
check() {
- cd "ghost2"
+ cd "${_dir}"
msg2 "Starting a simple search"
echo "go" | "./${_binary}" -sd 3 || \
(error "Simple search failed with an unknown error" ; \
if test "$CARCH" == x86_64 ; \
then error "Note: The 64-bit binary assumes that your CPU supports the POPCNT operation"; \
- error "If you saw an illegal instruction crash, you can try the non-popcnt version:"; \
- error "${_urlprefix}/ghost2_x64_linux_v${pkgver}_non_popcnt.tgz"; \
- error "sha256sum: c991c43834b5a1360c29aa6437aa4edf6c7a85fb49c6b4ac02e3e342b86fa438"; \
+ error "If you saw an illegal instruction crash, you can try the non-popcnt version (search for POPCNT in the PKGBUILD)"; \
fi ; false) && msg2 "Simple search completed without errors"
}
package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "ghost2"
+ cd "${_dir}"
install -Dm755 ${_binary} "$pkgdir/usr/share/$pkgname/ghost"
install -Dm644 kp_kp.gbb "$pkgdir/usr/share/$pkgname/kp_kp.gbb"
install -Dm644 kpp_kp_ram.gbb "$pkgdir/usr/share/$pkgname/kpp_kp_ram.gbb"