summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 762d7d59abca..1f1151c3d211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
+# Contributor: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
pkgname=ghostwriter-git
-pkgver=v1.8.0.r0.g78d7f3a
+pkgver=2.1.0.r0.g2495f9b
pkgrel=1
-pkgdesc="ghostwriter is a cross-platform, aesthetic, distraction-free Markdown editor."
+pkgdesc="Cross-platform, aesthetic, distraction-free Markdown editor."
arch=(i686 x86_64)
url="https://github.com/wereturtle/ghostwriter"
license=('GPL3')
-source=(git://github.com/wereturtle/ghostwriter.git)
-sha256sums=('SKIP')
conflicts=('ghostwriter')
provides=('ghostwriter')
makedepends=('git' 'qt5-tools')
depends=('qt5-base' 'qt5-svg' 'hunspell' 'desktop-file-utils'
- 'gtk-update-icon-cache' 'markdown' 'qt5-webengine')
+ 'gtk-update-icon-cache' 'discount' 'qt5-webengine')
optdepends=('hunspell: spell checking')
+source=(git+https://github.com/wereturtle/ghostwriter.git)
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {