summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a357465b4ba4..4fbd95d8d69a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Kohei Suzuki <eagletmt@gmail.com>
pkgname=ghq
-pkgver=0.17.0
+pkgver=0.17.1
pkgrel=1
pkgdesc="Remote repository management made easy"
arch=('i686' 'x86_64')
@@ -10,28 +10,35 @@ url="https://github.com/motemen/ghq"
license=('MIT')
makedepends=('go' 'git')
optdepends=('zsh: ghq function for zsh')
-source=("ghq-${pkgver}.tar.gz::https://github.com/motemen/ghq/archive/v${pkgver}.tar.gz")
+source=("git+https://github.com/motemen/${pkgname}.git")
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout "v${pkgver}"
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}"
export GOPATH="$srcdir/build"
go get -t -d -v
- go build .
+ make build
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}"
export GOPATH="$srcdir/build"
- go test -x -v .
+ make test
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}"
+
install -Dm 755 ghq "$pkgdir/usr/bin/ghq"
- install -Dm 644 zsh/_ghq "$pkgdir/usr/share/zsh/site-functions/_ghq"
+ install -Dm 644 misc/bash/_ghq "$pkgdir/usr/share/bash-completion/completions/_ghq"
+ install -Dm 644 misc/zsh/_ghq "$pkgdir/usr/share/zsh/site-functions/_ghq"
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/ghq/LICENSE"
}
# vim: set et sw=2 sts=2:
-sha512sums=('56a850c27514b7b522dd50d9810e8e5410d81458cdcc828c48435ef4dda2ffee1328c6924af55fee11e7ecc82274f95b70bb8bcae45b4cb899b98b48a6c5ae5e')
+sha512sums=('SKIP')