summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db5f887b4597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
+
+pkgname=gifsicle-git
+pkgver=1.93.r0.g416518e
+pkgrel=1
+pkgdesc='Command-line tool for creating, editing, and getting information about GIF images and animations (git version)'
+arch=('x86_64')
+url='https://www.lcdf.org/gifsicle/'
+license=('GPL2')
+optdepends=('libx11: for gifview tool')
+makedepends=('git' 'libx11')
+provides=('gifsicle')
+conflicts=('gifsicle')
+source=('git+https://github.com/kohler/gifsicle.git')
+sha256sums=('SKIP')
+
+prepare() {
+ autoreconf -fi gifsicle
+}
+
+pkgver() {
+ git -C gifsicle describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd gifsicle
+ ./configure --prefix='/usr'
+ make
+}
+
+check() {
+ gifsicle/test/testie -p gifsicle/src gifsicle/test
+}
+
+package() {
+ make -C gifsicle DESTDIR="$pkgdir" install
+}