summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b28884a63b65..dc6a39ddca4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gimp
pkgname=${_pkgname}-devel
pkgver=2.99.12
-pkgrel=1
+pkgrel=2
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.gimp.org/"
@@ -34,9 +34,18 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'lua51-lgi: LUA scripting support')
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
-source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz linux.gpl)
+source=("https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz"
+ 'fix_build_with_libheif_1.13.patch::https://gitlab.gnome.org/GNOME/gimp/-/commit/a61299ddb184babca015a846c72bf3e1a57faf2a.patch'
+ 'linux.gpl')
sha256sums=('7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3'
+ '6b3dbe50b85ec058f652b84ad7c959319618b8f5c23a9626face074ae3256aaf'
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -Np1 -i ../fix_build_with_libheif_1.13.patch
+}
+
build() {
local meson_options=(
)