summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0772e43a63c7..b28884a63b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
_pkgname=gimp
pkgname=${_pkgname}-devel
-pkgver=2.99.10
-pkgrel=2
+pkgver=2.99.12
+pkgrel=1
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.gimp.org/"
license=('GPL' 'LGPL')
depends=('gtk3' 'lcms2' 'libwmf' 'icu' 'enchant' 'libgexiv2' 'librsvg' 'desktop-file-utils'
'libexif' 'libgudev' 'openjpeg2' 'poppler-glib' 'poppler-data' 'openexr' 'mypaint-brushes1'
- 'babl>=0.1.78' 'gegl>=0.4.36' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
-makedepends=('intltool' 'libxslt' 'glib-networking'
+ 'babl>=0.1.78' 'gegl>=0.4.38' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
+makedepends=('appstream' 'intltool' 'libxslt' 'glib-networking'
'alsa-lib' 'curl' 'ghostscript' 'libxpm'
'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib' 'libjxl'
'gjs' 'luajit' 'meson' 'gobject-introspection'
- 'gi-docgen' 'xorg-server-xvfb' 'vala' 'highway') #'yelp-tools')
+ 'gi-docgen' 'xorg-server-xvfb' 'vala' 'highway' 'meson') #'yelp-tools')
checkdepends=('xorg-server-xvfb')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
'alsa-lib: for MIDI event controller module'
@@ -34,26 +34,19 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'lua51-lgi: LUA scripting support')
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
-source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2 linux.gpl)
-sha256sums=('9e08f1c4a455e8dd4dd0579fe289419e38c835db38e3c0d40cd1137fb0112f29'
+source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz linux.gpl)
+sha256sums=('7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3'
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
build() {
- cd "${_pkgname}-${pkgver}"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib/gimp \
- --datarootdir=/usr/share \
- --enable-mp \
- --enable-gimp-console \
- --enable-gi-docgen
-# --enable-g-ir-doc
- make
+ local meson_options=(
+ )
+
+ arch-meson "${_pkgname}-${pkgver}" build "${meson_options[@]}"
+ meson compile -C build
}
package() {
- cd "${_pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ meson install -C build --destdir "$pkgdir"
+
install -Dm 644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.99/palettes/Linux.gpl"
}