summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ea7c7a09337..0852b9d79800 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gimp
pkgname=${_pkgname}-devel
-pkgver=2.99.6
+pkgver=2.99.8
pkgrel=1
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -10,10 +10,10 @@ url="http://www.gimp.org/"
license=('GPL' 'LGPL')
depends=('gtk3' 'lcms2' 'libwmf' 'icu' 'enchant' 'libgexiv2' 'librsvg' 'desktop-file-utils'
'libexif' 'openjpeg2' 'poppler-glib' 'poppler-data' 'openexr' 'mypaint-brushes1'
- 'babl>=0.1.78' 'gegl>=0.4.30' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
+ 'babl>=0.1.78' 'gegl>=0.4.32' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
makedepends=('intltool' 'libxslt' 'glib-networking'
'alsa-lib' 'curl' 'ghostscript' 'libxpm' 'webkit2gtk'
- 'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib'
+ 'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib' 'libjxl'
'gjs' 'luajit' 'meson' 'gobject-introspection'
'gtk-doc' 'xorg-server-xvfb' 'vala')
checkdepends=('xorg-server-xvfb')
@@ -24,6 +24,7 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'libxpm: XPM support'
'webkit2gtk: HTML renderer and web content engine'
'libheif: HEIF support'
+ 'libjxl: JPEG XL support'
'libwebp: WebP support'
'libmng: MNG support'
'iso-codes: Language support'
@@ -35,7 +36,7 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2 linux.gpl)
-sha256sums=('8d264b28445a3df2b940f30ee0b89b469255e975e8563b889fd57fb2f58f66a0'
+sha256sums=('dd916bd3474ef2efc652a0510280977ab8ea95e3d95d918394b0662261c32aae'
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
build() {
cd "${_pkgname}-${pkgver}"