summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 28 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 436b46d3d42b..15d9cd0fa007 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,30 @@
# Contributor: andre.vmatos
_pkgname=resynthesizer
-pkgname=gimp-plugin-$_pkgname-git
+pkgname=gimp3-plugin-${_pkgname}-git
pkgver=2.0.3.r24.gecfc4e7
pkgrel=1
-pkgdesc="Suite of gimp plugins for texture synthesis (like heal-selection). Git-Version"
+pkgdesc="Suite of gimp plugins for texture synthesis (like heal-selection), ported to GIMP 3. Git-Version"
arch=('i686' 'x86_64')
url="https://github.com/bootchk/resynthesizer"
license=('GPL2')
-depends=('python2-gimp')
-makedepends=('git' 'intltool')
-conflicts=('gimp-resynth' 'gimp-resynth-git')
-provides=("${pkgname/-git/}=2.0")
+depends=(
+ 'gimp>=2.99'
+ python
+ python-gobject
+)
+makedepends=(
+ git
+ intltool
+ meson
+)
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}=$pkgver")
options=('!emptydirs')
-source=('git+https://github.com/bootchk/resynthesizer#branch=master')
-md5sums=('SKIP')
+source=('git+https://github.com/bootchk/resynthesizer#branch=resynthesizer3'
+ "$_pkgname-0001-Fix-format-security-warning-in-debug.c.patch::$url/pull/130.patch")
+b2sums=('SKIP'
+ '35cc86808385984950bfa811d20422ba1082ecfb280f18ee42faa8b86b78e53b0cd354c818ac51efa15daab24190b864c08f8a6c8e821f079368a9fa6a319253')
pkgver() {
@@ -26,18 +36,21 @@ pkgver() {
prepare() {
cd $_pkgname
- sed -i 's/--enable-maintainer-mode//g' autogen.sh
+ # See https://github.com/bootchk/resynthesizer/pull/130
+ patch -Np1 < ../$_pkgname-0001-Fix-format-security-warning-in-debug.c.patch
+ # Remove Ubuntu-ism
+ sed -i 's@x86_64-linux-gnu/@@g' meson.build
}
build() {
- cd $_pkgname
+ arch-meson --prefix '/usr' builddir $_pkgname
+ meson compile -C builddir
+}
- ./autogen.sh --disable-maintainer-mode --prefix=/usr
- make
+check() {
+ meson test -C builddir
}
package() {
- cd $_pkgname
-
- make DESTDIR="$pkgdir/" install
+ meson install -C builddir --destdir "$pkgdir"
}