summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2521b074ff24..a1bfb6af674b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Philipp Schaffrath <aur at philipp dot schaffrath dot email>
+# Maintainer: Philipp Schaffrath <philipp dot schaffrath at gmail dot com>
pkgname=giph-git
-pkgver=v1.0.r0.gd7eccda
+pkgver=1.1.1.r6.g6cee978
pkgrel=1
-pkgdesc='gif recorder that records the desktop, a window or a selection'
+pkgdesc='video recorder that records the desktop, a window or a selection'
url='https://github.com/phisch/giph'
license=('MIT')
arch=('any')
depends=('bash' 'ffmpeg' 'xdotool')
optdepends=('slop: for interactive selection'
- 'libnotify: for error and success notifications')
+ 'libnotify: for error and success notifications'
+ 'procps-ng: for pgrep used in the --stop flag')
makedepends=('git')
provides=('giph')
conflicts=('giph')
-source=("$pkgname::git://github.com/phisch/giph.git")
+source=("$pkgname::git+https://github.com/phisch/giph.git")
sha256sums=('SKIP')
pkgver() {
@@ -26,6 +27,6 @@ pkgver() {
package() {
cd "$pkgname"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file