summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b0813ef5a3d..f6fee1f8dc11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgname=(
"$pkgbase"
"${pkgbase}-extras"
)
-pkgver=2.0.785
+pkgver=2.0.877
pkgrel=1
pkgdesc="A secure Git credential helper built on .NET that runs on Windows, macOS, and Linux"
arch=(i686 x86_64)
url="https://github.com/GitCredentialManager/git-credential-manager"
license=('MIT')
-makedepends=(git dotnet-sdk 'dotnet-runtime>=6' dpkg)
-checkdepends=(dotnet-runtime-5.0)
+makedepends=(git dotnet-sdk dpkg)
+checkdepends=(dotnet-runtime-6.0)
provides=($pkgname)
conflicts=("${pkgname}-bin")
replaces=(git-credential-manager)
@@ -22,13 +22,15 @@ source=("$pkgbase::git+$url.git#tag=v$pkgver"
sha256sums=('SKIP'
'3eb41718ef9c701307a6ca7ef85b6993d93fe55b5ad4fad632ff5722779397cf')
-prepare() {
- cd "$pkgbase"
+# Seems that trimming is not required, either because of newer .NET or project changes
+# Feel free to uncomment these lines if needed
+#prepare() {
+ #cd "$pkgbase"
# Based on this chinese article:
# https://live4thee.github.io/posts/2021-02-09-dotnet-core-on-linux-2/
# Thanks web translators :P
- git apply ../trim-executables.diff
-}
+ #git apply ../trim-executables.diff
+#}
build() {
cd "$pkgbase"
@@ -49,11 +51,15 @@ package_git-credential-manager-core() {
mkdir -p "$pkgdir/usr/lib/share/$pkgname"
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- for bin in git-credential-manager-core
+ for bin in git-credential-manager
do
cp "out/linux/Packaging.Linux/payload/Release/$bin" "$pkgdir/usr/lib/share/$pkgname"
ln -s "/usr/lib/share/$pkgname/$bin" "$pkgdir/usr/bin/$bin"
done
+ # Deal with the different naming convention
+ # https://github.com/GitCredentialManager/git-credential-manager/pull/551
+ # https://github.com/GitCredentialManager/git-credential-manager/blob/main/docs/rename.md
+ ln -s "/usr/lib/share/$pkgname/git-credential-manager" "$pkgdir/usr/bin/$pkgname"
cp LICENSE "$pkgdir/usr/share/licenses/$pkgname"
}