summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c74daed736fe..ba538e66a83d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ license=('GPL2')
depends=('python-git' 'python-phabricator' 'python-argcomplete' 'python-appdirs')
provides=("$_pkgname")
conflicts=("$_pkgname")
-makedepends=('git')
+makedepends=('git' 'asciidoc')
source=("$_pkgname::git://anongit.freedesktop.org/git/$_pkgname")
md5sums=('SKIP')
@@ -20,9 +20,14 @@ pkgver() {
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/$_pkgname"
+ a2x --doctype manpage --format manpage git-phab.txt
+}
+
package() {
cd "$srcdir/$_pkgname"
install -Dm755 git-phab "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 git-phab.txt "$pkgdir/usr/share/doc/$_pkgname/$_pkgname.txt"
+ install -Dm644 git-phab.1 "$pkgdir/usr/share/man/man1/$_pkgname.1"
install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README"
}