summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2cfadb8a388
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=git-quick-git
+pkgver=0.0.0.r5.ga948b44
+pkgrel=1
+_branch=master
+pkgdesc="edit a subset of files from a git repository on any branch"
+arch=('x86_64')
+url="https://github.com/qwertzguy/${pkgname%-git}"
+license=('MIT')
+makedepends=('git')
+depends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git://github.com/qwertzguy/${pkgname%-git}.git#branch=$_branch")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git tag v0.0.0 8c8b03a ||:
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm 755 {.,$pkgdir/usr/bin}/${pkgname%-git}
+}