summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 299a8ceea0c9..b5433dfb591e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Abdó Roig-Maranges <abdo.roig@gmail.com>
-pkgname=git-spindle-git
-pkgver=3.3.r16.g6a6c920
+pkgname=git-spindle
+pkgver=3.3
pkgrel=1
pkgdesc="Git subcommands for integrating with central services like github, gitlab and bitbucket"
arch=('any')
@@ -10,17 +10,11 @@ license=('GPL3')
depends=('git' 'python' 'python-github3' 'python-whelk' 'python-docopt')
makedepends=('make' 'python-sphinx')
optdepends=()
-provides=('git-spindle')
-conflicts=('git-spindle')
-source=("git+https://github.com/seveas/git-spindle.git")
-md5sums=('SKIP')
-
-pkgver() {
- git --git-dir="$srcdir/git-spindle/.git" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("https://github.com/seveas/git-spindle/archive/${pkgver}.tar.gz")
+sha256sums=('4bfad8e716e16e267c1297bb66b563a5eb4a3f90d618338442529a9c773bd4d1')
prepare() {
- cd "${srcdir}/git-spindle"
+ cd "${srcdir}/git-spindle-${pkgver}"
# NOTE: Since we only build the man page, we tweak docs configuration so that
# it does not require a sphinx theme.
@@ -28,14 +22,14 @@ prepare() {
}
build() {
- cd "$srcdir/git-spindle"
+ cd "$srcdir/git-spindle-${pkgver}"
python setup.py build
LANG=en_US.UTF-8 make -C docs man
}
package() {
- cd "$srcdir/git-spindle"
+ cd "$srcdir/git-spindle-${pkgver}"
python setup.py install --prefix=/usr --root="$pkgdir"
install -d "$pkgdir/usr/share/man/man1/"