summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..861c438403f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=git-xargs
+_pkgname=git-xargs
+pkgver=0.0.5
+pkgdesc='git-xargs is a command-line tool (CLI) for making updates across multiple Github repositories with a single command.'
+pkgrel=1
+arch=('i686' 'x86_64')
+url='https://github.com/gruntwork-io/git-xargs'
+source=("https://github.com/gruntwork-io/git-xargs/archive/refs/tags/v${pkgver}.tar.gz")
+depends=()
+makedepends=('go')
+sha256sums=('958e58ef35f03b02ef9601a0859c9178e6f0e8aa58717f09e91e4a43cd9bd4b3')
+license=('Apache')
+
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
+ GO111MODULE=on go build -o "$srcdir/bin/git-xargs"
+}
+
+package() {
+ cd "$srcdir/bin"
+ install -Dm755 'git-xargs' "$pkgdir/usr/bin/git-xargs"
+}