aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcea6d79b934..29e118d60699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Tim Kleinschmidt <tim.kleinschmidt@gmail.com>
# Contributor: Marcin Wieczorek <marcin@marcin.co>
# Contributor: Jean-Pier Brochu <jeanpier.brochu@gmail.com>
+# Contributor: Samuel Littley <samuel@samuellittley.me>
pkgname=gitkraken
-pkgrel=1
+pkgrel=2
pkgver=2.2.0
pkgdesc="The intuitive, fast, and beautiful cross-platform Git client."
url="http://www.gitkraken.com/"
@@ -19,11 +20,13 @@ source=(
"GitKraken.desktop"
"gitkraken.png"
"eula.html"
+ "gitkraken.sh"
)
md5sums=('60ef26ca66f7d73ae29e53b557b69350'
- 'ecef298bed1178d60cf0dd75c4700205'
+ '55f11789f5a9ee9fc4989d0f06eee260'
'04987b933d551d15c0813111d715bb9e'
- 'e9ba6663e5f1f92cae31beb0074e8c6c')
+ 'e9ba6663e5f1f92cae31beb0074e8c6c'
+ 'e3063947b063aaccf4dc17ed47437ea8')
package() {
install -d "$pkgdir"/opt
@@ -33,8 +36,8 @@ package() {
chmod 755 "$pkgdir"/opt/gitkraken/gitkraken
install -d "$pkgdir"/usr/bin
- ln -s ../../opt/gitkraken/gitkraken "$pkgdir"/usr/bin/gitkraken
+ install -D -m755 "./gitkraken.sh" "${pkgdir}/usr/bin/gitkraken"
install -D -m644 "./eula.html" "${pkgdir}/usr/share/licenses/${pkgname}/eula.html"
install -D -m644 "./GitKraken.desktop" "${pkgdir}/usr/share/applications/GitKraken.desktop"
install -D -m644 "./gitkraken.png" "${pkgdir}/usr/share/pixmaps/gitkraken.png"