summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49d874c52697..012c4d86eea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Doug Johnson <dougvj at dougvj dot net>
pkgname=gitlab-ci-local-git
pkgver=4.23.0.r0.g2195c19
-pkgrel=1
+pkgrel=2
source=('gitlab-ci-local-git::git+https://github.com/firecow/gitlab-ci-local.git')
md5sums=('SKIP')
pkgdesc="Run gitlab pipelines locally as shell executor or docker executor"
@@ -9,11 +9,15 @@ arch=('i686' 'x86_64')
url="https://github.com/firecow/gitlab-ci-local"
license=('MIT')
makedepends=('git' 'sed' 'npm' 'typescript')
-depends=('ts-node')
+
+# TODO Don't bundle ts-node with the build perhaps
+# so we can use the system's version
+#depends=('ts-node')
pkgver() {
cd "$pkgname"
git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+options=("!strip")
build() {
cd "$pkgname"