summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49d874c52697
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Doug Johnson <dougvj at dougvj dot net>
+pkgname=gitlab-ci-local-git
+pkgver=4.23.0.r0.g2195c19
+pkgrel=1
+source=('gitlab-ci-local-git::git+https://github.com/firecow/gitlab-ci-local.git')
+md5sums=('SKIP')
+pkgdesc="Run gitlab pipelines locally as shell executor or docker executor"
+arch=('i686' 'x86_64')
+url="https://github.com/firecow/gitlab-ci-local"
+license=('MIT')
+makedepends=('git' 'sed' 'npm' 'typescript')
+depends=('ts-node')
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ npm install
+ npm run build
+}
+
+package() {
+ cd "$pkgname"
+ npm run pkg-linux
+ mkdir -p $pkgdir/usr/bin
+ cp ./bin/linux/gitlab-ci-local $pkgdir/usr/bin
+}
+