summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c699487676e2..feb8bb7196fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=glade-dev
pkgver=3.19.0
-pkgrel=2
+pkgrel=3
pkgdesc="User interface builder for GTK+ and GNOME."
arch=(i686 x86_64)
license=('GPL' 'LGPL')
@@ -12,22 +12,24 @@ makedepends=('intltool' 'gtk-doc' 'gobject-introspection' 'python2-gobject' 'its
optdepends=('python2: Python widgets support'
'devhelp: help browser')
url="http://glade.gnome.org/"
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
install=glade.install
-source=(http://ftp.gnome.org/pub/GNOME/sources/glade/${pkgver:0:4}/glade-$pkgver.tar.xz)
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname%-*}/${pkgver:0:4}/${pkgname%-*}-$pkgver.tar.xz)
sha256sums=('a7a3f6d32fbfcc9b754b48a3410bf025e462bc7898e124f0ad8f64c3d7ad6fa2')
prepare() {
- cd "glade-$pkgver"
+ cd "${pkgname%-*}-$pkgver"
}
build() {
- cd "glade-$pkgver"
+ cd "${pkgname%-*}-$pkgver"
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --disable-static
make
}
package() {
- cd "glade-$pkgver"
+ cd "${pkgname%-*}-$pkgver"
make DESTDIR="$pkgdir" install
}