summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab44e61b15f8..a278abc6d4ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,21 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=glances-git
-pkgver=3.1.6.1.r30.gd201e647
+pkgver=3.4.0.r541.g1de207e
pkgrel=1
-pkgdesc='CLI curses-based monitoring tool'
+pkgdesc='CLI curses-based monitoring tool (git)'
arch=(any)
url=https://github.com/nicolargo/glances
-license=(LGPL)
-makedepends=(git)
-depends=(python python-psutil python-setuptools python-future)
+license=(LGPL-3.0-only)
+makedepends=(python-setuptools python-build python-installer python-wheel git)
+depends=(python python-psutil python-future python-defusedxml python-ujson python-pytz python-pydantic)
optdepends=('hddtemp: HDD temperature monitoring support'
'python-bottle: web server support'
'python-docker: for the Docker monitoring support'
'python-matplotlib: for graphical/chart support'
'python-netifaces: for the IP plugin'
- 'python-zeroconf: for the autodiscover mode')
+ 'python-zeroconf: for the autodiscover mode'
+ 'python-pystache: templating engine')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=(git+"${url}".git
@@ -27,16 +28,21 @@ sha512sums=('SKIP'
'49f0d185a37a5c5837e5beb463770c943ede40b2f1b8405e338129e897e97d9fc58373a8586fabc506266e6343cfea3c91b9787ac6832cc97a1ab63d6ad058d4')
pkgver() {
- git -C "${pkgname%-git}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "${pkgname%-git}" describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ # Clean out old wheels etc.
+ git -C "${pkgname%-git}" clean -dfx
}
build() {
cd "${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname%-git}"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "${srcdir}"/glances.service -t "${pkgdir}"/usr/lib/systemd/system
}