summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8f162d93b8b..c1bc68795502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=glib
pkgver=1.2.10
-pkgrel=17
+pkgrel=18
pkgdesc="Common C routines used by Gtk+ and other libs"
arch=('i686' 'x86_64' 'armv6h')
url="http://www.gtk.org/"
@@ -23,8 +23,6 @@ prepare() {
patch -Np0 -i "${srcdir}/aclocal-fixes.patch"
patch -Np1 -i "${srcdir}/glib1-autotools.patch"
sed -i -e 's/ifdef[[:space:]]*__OPTIMIZE__/if 0/' glib.h
- # Could alternatively turn off -Werror=format-security
- sed -i -e "/g_print (string);/d" testglib.c
rm acinclude.m4
}
@@ -39,7 +37,7 @@ build() {
fi
autoreconf --force --install
- ./configure --prefix=/usr --mandir=/usr/share/man \
+ CFLAGS="-Wno-format-security" ./configure --prefix=/usr --mandir=/usr/share/man \
--infodir=/usr/share/info $CONFIGFLAG
make
}