summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ef614b8fbc9..c1bc68795502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=glib
pkgver=1.2.10
-pkgrel=13
+pkgrel=18
pkgdesc="Common C routines used by Gtk+ and other libs"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h')
url="http://www.gtk.org/"
license=('LGPL')
depends=('glibc' 'sh')
options=('!makeflags')
-install=glib.install
-source=(ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/${pkgname}-${pkgver}.tar.gz
+source=(https://download.gnome.org/sources/glib/1.2/${pkgname}-${pkgver}.tar.gz
gcc340.patch aclocal-fixes.patch glib1-autotools.patch)
sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
'a2cc224a66aeffdcac16ebd9e8af18143cf54918'
@@ -24,6 +23,7 @@ prepare() {
patch -Np0 -i "${srcdir}/aclocal-fixes.patch"
patch -Np1 -i "${srcdir}/glib1-autotools.patch"
sed -i -e 's/ifdef[[:space:]]*__OPTIMIZE__/if 0/' glib.h
+ rm acinclude.m4
}
build() {
@@ -32,10 +32,12 @@ build() {
CONFIGFLAG='--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu'
elif [[ $CARCH = "x86_64" ]]; then
CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
+ elif [[ $CARCH = "armv6h" ]]; then
+ CONFIGFLAG='--host=armv6l-unknown-linux-gnueabihf --target=armv6l-unknown-linux-gnueabihf'
fi
autoreconf --force --install
- ./configure --prefix=/usr --mandir=/usr/share/man \
+ CFLAGS="-Wno-format-security" ./configure --prefix=/usr --mandir=/usr/share/man \
--infodir=/usr/share/info $CONFIGFLAG
make
}