summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD119
1 files changed, 78 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1982301a9bca..f299339006b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,70 +1,107 @@
-# Maintainer: dudemanguy <random342@airmail.cc>
+# Maintainer: Dudemanguy <random342@airmail.cc>
# Contributor: Vaporeon <vaporeon@vaporeon.io>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=glib2-patched-thumbnailer
-pkgver=2.60.7
-pkgrel=1
+pkgver=2.80.0
+pkgrel=2
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
-url="https://gist.github.com/Dudemanguy911/d199759b46a79782cc1b301649dec8a5"
+url="https://gist.github.com/Dudemanguy/d199759b46a79782cc1b301649dec8a5"
arch=(x86_64)
-provides=("glib2=$pkgver")
+provides=(glib2=$pkgver libg{lib,io,irepository,module,object,thread}-2.0.so)
conflicts=('glib2')
-depends=(pcre libffi libutil-linux zlib tumbler)
-makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux meson dbus)
-checkdepends=(desktop-file-utils)
+depends=(pcre2 libffi util-linux-libs zlib tumbler libsysprof-capture libmount.so libffi.so)
+makedepends=(
+ dbus
+ gettext
+ git
+ gi-docgen
+ gobject-introspection
+ libelf
+ meson
+ python
+ python-docutils
+ shared-mime-info
+ util-linux
+)
+checkdepends=(desktop-file-utils glib2)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
- 'libelf: gresource inspection tool')
-options=('!docs' '!emptydirs')
-license=(LGPL2.1)
-_commit=a7da87e3e8dad5e53b2acf10617485d137a44ca5 # tags/2.60.7^0
-source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
- noisy-glib-compile-schemas.diff
- glib-compile-schemas.hook
- gio-querymodules.hook
- glib-thumbnailer.patch)
-sha256sums=('SKIP'
- '81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
- 'e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3'
- '5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6'
- '9ea789788962a941af83b99949ddc21d7d19d820f2170f58691ca83e53afb158')
+ 'libelf: gresource inspection tool'
+ 'gvfs: most gio functionality')
+options=(!docs staticlibs)
+license=(LGPL)
+_commit=763cc3b238398614c20069fd67642730e3a6519b # tags/2.80.0^0
+source=(
+ "git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/gvdb.git"
+ 0001-glib-compile-schemas-Remove-noisy-deprecation-warnin.patch
+ 0002-glocalfileinfo-add-a-dbus-thumbnail-generator.patch
+ gio-querymodules.hook
+ glib-compile-schemas.hook
+)
+b2sums=('cc3a6a7a14fef1aabc08d3bdfe98f66e3ecf3591ac054d83aa9404c8c9cd72e690a4c26c16934700d067bb2cb3d58730387482032cd9ffa04b041869426165ba'
+ 'SKIP'
+ '94c73ca7070c239494873dd52d6ee09382bbb5b1201f7afd737cfa140b1a2fb0744b2c2831baf3943d1d072550c35888d21ce6f19f89481ff9d1a60d9a0b30e0'
+ '5eed57eccc15fa9994228815874200135e9ee682b9bd718dae4b486eb3a65f2efb8121f45afedd4dd33208297738b5f1f489cb9a798a896540a505b32a37cc08'
+ '14c9211c0557f6d8d9a914f1b18b7e0e23f79f4abde117cb03ab119b95bf9fa9d7a712aa0a29beb266468aeb352caa3a9e4540503cfc9fe0bbaf764371832a96'
+ 'd30d349b4cb4407839d9074ce08f5259b8a5f3ca46769aabc621f17d15effdb89c4bf19bd23603f6df3d59f8d1adaded0f4bacd0333afcab782f2d048c882858')
pkgver() {
cd glib
- git describe --tags | sed 's/-/+/g'
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
cd glib
# Suppress noise from glib-compile-schemas.hook
- patch -Np1 -i ../noisy-glib-compile-schemas.diff
+ git apply -3 ../0001-glib-compile-schemas-Remove-noisy-deprecation-warnin.patch
# Apply patch to generate thumbnails
- patch -Np1 -i ../glib-thumbnailer.patch
+ git apply -3 ../0002-glocalfileinfo-add-a-dbus-thumbnail-generator.patch
+
+ git submodule init
+ git submodule set-url subprojects/gvdb "$srcdir/gvdb"
+ git -c protocol.file.allow=always submodule update
}
build() {
- CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
- arch-meson glib build \
- -D selinux=disabled \
- -D man=true \
- -D gtk_doc=true
- ninja -C build
+ local meson_options=(
+ --default-library both
+ -D glib_debug=disabled
+ -D introspection=enabled
+ -D man-pages=enabled
+ -D selinux=disabled
+ -D sysprof=enabled
+ )
+
+ # Produce more debug info: GLib has a lot of useful macros
+ CFLAGS+=" -g3"
+ CXXFLAGS+=" -g3"
+
+ # use fat LTO objects for static libraries
+ CFLAGS+=" -ffat-lto-objects"
+ CXXFLAGS+=" -ffat-lto-objects"
+
+ arch-meson glib build "${meson_options[@]}"
+ meson compile -C build
}
-#skip this; test fails
-#check() {
-# meson test -C build --no-suite flaky --print-errorlogs
-#}
+check() {
+ meson test -C build --no-suite flaky --no-suite slow --print-errorlogs
+}
package() {
- DESTDIR="$pkgdir" meson install -C build
- install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
+ meson install -C build --destdir "$pkgdir"
- python -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
- python -O -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
+ touch "$pkgdir/usr/lib/gio/modules/.keep"
- # Split docs
- mv "$pkgdir/usr/share/gtk-doc" "$srcdir"
+ python -m compileall -d /usr/share/glib-2.0/codegen \
+ "$pkgdir/usr/share/glib-2.0/codegen"
+ python -O -m compileall -d /usr/share/glib-2.0/codegen \
+ "$pkgdir/usr/share/glib-2.0/codegen"
}
+
+# vim:set sw=2 sts=-1 et: